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Get Started  
 

 
 

 STEP 1: RESTART YOUR COMPUTER (refresh your RAM) 
Restart your computer at the start and during any work session (several times) because your computer 
will slow down gradually when you use big programs like Premiere Pro. It means your RAM is running 
low (Random Access Memory). RAM refreshes when you restart your computer. 
 

  FOLLOW THE FIRST SETUP STEPS BELOW (even if you know Premiere Pro) 
You could lose your project or a lot of time if it’s not set up properly. Please follow the steps below until 
we get to “Choose Your Path” section, where you can choose “Advanced” to take off on your own or 
“Beginner” to complete your project step-by-step. 
 

 WORKSPACE OVERVIEW:   
Below is your workspace. Change the size of any panel by clicking and dragging. 
 
  

 
 
 

 
 
 

Back To Top 

Project Panel  
(includes Media Browser) 
Import your videos, photos, etc., here 
(drag/drop) and perform many other tasks. 

Timeline Panel 
Drag video clips here from the project panel.  
First, start a new sequence (Cntrl/Command-N) 

Program Panel 
Play video that’s currently on your timelne. 

Effects Controls 
Optional way to input properties numerically 
(such as scale, position, opacity, rotation, etc.) 
Source Panel  
Pre-edit clips you want to use before dragging 
them to the timeline, or add effects 



 
 3 

 
Organize Your Files   

 
 

 ORGANIZED FILES vs. LOST FILES  
You’ll risk losing your whole project easily if your files are not properly organized. So this is the most 
important step you will take in your project. 
 

                   
 

 CLASS PROJECT (simple organization)         
 

 

1. Create a master folder on your desktop. 
2. Inside that folder, create individual folders 

for your music, videoclips, and images 
(name them whatever you choose).  

3. Never rename or move these folders after 
they’re created. 

4. If you want to move or copy your project 
(e.g., to back it up), move the whole master 
folder with all the files inside. 

5. When you want to open your project to 
work on it, open the project file from 
inside your master folder, NOT from inside 
Premiere Pro. 
 
WHY? Because students can get confused when Premiere 
Pro shows them images of the most recent files it detects—
these may or may not be your real files. Your files do not 
exist inside Premiere Pro—they are on your laptop (backed 
up to the cloud server you choose).  

 
 PRO PROJECT (example of elaborate file organization) 

You don’t need to do this now, but keep in mind pros use different file naming conventions for elaborate projects. 
 

 

 

Back To Top 
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Create a New Project in Premiere   
 

 
 OPEN PREMIERE. Click “New Project” button. 
 

 
 

 NAME YOUR PROJECT  
 

1. In the new screen, ignore all images Adobe is trying to sell you (or hook you on). 
2. In the top left “Project Name” area, name your video (this will be the name of your saved file). 

 

 

 

 

 

Back To Top 
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 CONNECT TO YOUR MASTER FOLDER 
1. Click on “Project Location” (upper center). 
2. Click “Choose Location.”  

 

 
 

3. Browse to your MASTER FOLDER, select it, and click “Select Folder,” then “Create.” 
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4. You will see your full workspace open for a new project. 

 

 
 
5. Check your master folder on your desktop. Open your master folder on your desktop to make sure it 
now contains your .prproj file inside, along with the folders you created. If it is not inside your master 
folder, start over from the top of these instructions.  
 

 
 
 

 SET “EDIT” WORKSPACE 
In Premiere, make sure you are in the “Edit” Workspace.  
 
Upper Left 
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Import Media   
 

 
DRAG AND DROP FOLDERS 
1. Open your MASTER FOLDER on your desktop to reveal the inside folders. 
2. Drag and drop those inside folders (video, music, image, etc.) into the Project Panel in Premiere. 
 
 

 
 
3. Click the “List View” icon at the bottom of the panel to see files easily. 
 

 
NOTE: Folders with just one file will show the file and not the folder (weird, I know). 
 
 

Back To Top 
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Create a New Timeline Sequence  
 

 
A sequence is the space where you build your video on a timeline. It includes your screen dimensions 
and other important specifications. 
 

 
 
STOP.  This isn’t the point yet to take off and experiment. Follow the steps below carefully below to 
set up your first sequence so you don’t get your project in trouble from the get-go. 
 

 DON’T DO THIS 
Don’t drag a video to your timeline area to start your sequence. While this works, it will cause your 
screen size to be created in whatever size the clip is that you dragged over. So, your whole video could 
be too small or too big.  
 

 DO THIS INSTEAD: CREATE A SEQUENCE 
Go to File > New > Squence OR use shortcut Command/Ctrl-N 

 

 
 

Back To Top 
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 SEQUENCE SETTINGS (your video dimensions)  
In the new window, click on “Settings” and enter the info in the side bar below. Enter the screen 
dimensions below OR see Sprout Social for Social media dimensions you might want. 
 
 

 

SETTINGS EXAMPLES 
FOR SOCIAL MEDIA: 
 
Editing Mode:  
DSLR or “Custom” 
 
Timebase: 29.97 frames/sec  
for high quality 
 
Frame Size  
[for horizontal videos]:  
1920 horizontal  
1080 vertical 
 
Frame Size  
[for vertical videos]:  
1080 horizontal 
1920 vertical 
 
Working Color Space:  
Rec. 709  
 
Check the Box: 
Auto Tone Map Media 
(adjusts iPhone colors properly) 
 
Click OK. 

 
 
 
 

 
 
 

https://sproutsocial.com/insights/social-media-video-specs-guide/#youtube
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You will see your new sequence, including: 

• a new timeline (this is where most of your work will be done) 
• a video screen area (black rectangle, upper right) 
• a new file called Sequence 01 in your project panel (lower left). 

 

 
 
 

 DRAG A VIDEO CLIP TO THE TIMELINE 
1. Now you can drag and drop a video from your videoclips folder to your timeline on the v1 track. 
2. You will see the video and audio tracks appear together in the timeline.  
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3. If you receive a warning that your clip does not match the sequence you created,  

click “Keep existing settings” to retain the dimensions of the video you’re creating (see below). 
 

 
 
 
 

 IF YOUR CLIP APPEARS A DIFFERENT SIZE THAN YOUR VIDEO SCREEN 
If your clip appears to be a different size than your video screen in the program panel: 
Double-click the clip and drag it larger or smaller (or use the options below).  
This is also how you can create the effect of a closer shot (closeup, etc.)  
NOTE: If you stretch your video too much, it could pixelate. 
 

 
 
 
OPTION 1: double-click the image of the video and drag it to larger or smaller dimensions as needed. 
OPTION 2: right-click on the clip on the timeline and select “Scale to Frame Size.” 
OPTION 3: In the Effects Control Panel (upper left), change scale of the clip  
(instead of 100%, type a new number).  
OPTION 4: Change your video screen to match your clip instead, if you want to (Sequence > Settings) 
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Effect Controls   
 

 
 
In the “Effect Controls” panel, you can control parameters of elements numerically (e.g., scale, position, 
opacity, rotation). For example: 
1. Select a video clip on your timeline. 
2. Open the “Effect Controls” panel (Window > Effect Controls). This window will appear upper left. 
3. Change the “Scale” of the clip from 100% to a larger or smaller percentage by typing in the new 

number or clicking on the left or right arrow. 
 
Notice you can also access this panel through a tab at the top of the panel. 
 
Other panels can change function, as well, through the tabs at the top of the panels. For example, some 
people like to change their Project Panel into an Effects panel (for transitions, etc.) by clicking the 
“Effects” Tab in the lower left panel. Then they open the Effect Controls Panel in the upper left. 
 
 

 
 
 
 
 
 
 
 
 
 
 

 

Back To Top 

2. Effect Controls Panel   

1. Effects Panel  
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Choose a Path: Beginner or Advanced 
 

 
Now is the time to choose how you want to proceed, based on your experience in Premiere Pro. 
 

 ADVANCED: You’ve Already Used Premiere Pro and Are Ready to Take Off 
View the 12-minute video below as a refresher and then take off on your own in Premiere Pro.  

 Quick Overview: Premiere Pro – Tutorial for Beginners in 12 Minutes [2022 Version] (Skills Factory) 

 Premiere Pro in 11 Minutes! [2023] 
The rest of this written tutorial is optional. Use the jump menu at the top as needed. 
 

 BEGINNER: You’d Like Step-by-step Instruction 
Continue following this written tutorial, and refer to the video below if it’s helpful. 

 In-Depth Video: Premiere Pro for Beginners 2023: Everything You Need to Know! [Updated] 
(Vince Opra) 

 

 

Get Around 
 

 
 PLAY YOUR VIDEO ON THE TIMELINE 

Click the “Play” button in the Program Panel where your video appears (upper right).  
This is where you will play your video to see how it looks as you create it.  
 

 
 
 

Back To Top 

Back To Top 

https://www.youtube.com/watch?v=V6ta4dbRD7E
https://www.youtube.com/watch?v=jTCxUXGM6tc
https://www.youtube.com/watch?v=keoszhf4DZ8
https://www.youtube.com/watch?v=keoszhf4DZ8
https://www.youtube.com/watch?v=V6ta4dbRD7E
https://www.youtube.com/watch?v=cxzXEakrYO4
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 HOW TO ZOOM & MOVE  
 
Zoom In/Out of Video Preview 
 

 
 
 
Move Your Playhead on the Timeline. Click on the top of the playhead (the blue vertical line). Drag it 
through the timeline, or click a new spot on the top of the timeline to make it jump there. 
 

 
 
Zoom in/out of Timeline. Use the slider at the bottom of the timeline or use Opt/Alt and your track pad. 
Click and drag the right circle to make the timeline larger or smaller. 
Click and drag the whole slider to move through your timeline. 
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Enlarge Timeline View. Select the bottom line of a track and drag it down or up. 
You will see images on your timeline get larger or smaller. 
 

 
 
 

 TIMELINE TRACK CONTROLS 
FYI: Take a look at your timeline track controls: 

 

 
 

 ADVANCED ZOOM & ZOOM ANIMATIONS 
YOUTUBE: “How to Zoom in on Premiere Pro (Tutorial)” by FilterGrade 
 

Eye Button Hides or reveals track 

M Mute a track 

Lock  Locks down track 

S Solos this audio track (no other sound) 

Microphone Allows you to record 

Mix (VOLUME)   
Increases/decreases volume of whole sequence 

To Delete/Add Track right click in vacant area 

https://www.youtube.com/watch?v=UxYyVKhvIK0
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Color Corrections   
 

 
 CORRECT COLOR/LIGHTING 

It’s a good idea to make color corrections on a clip before you cut it and start editing. 
1. If you have a top menu option for “Color” select it, and you will see the color effects controls open 

in a panel on the right. Change the settings as needed. 
2. However, if you have the updated version, see the second screenshot.  
 

 
 
For the new version, it’s a little more complex:  
1. Select the Workspace button (upper right) 
2. Select “Effects.” You will see an Effects panel open on the right. 
3. Go to Window > Lumetri Color to see the settings like the ones in pic above. 
 

    
                           
 

Back To Top 
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 ADVANCED: COLOR GRADING (Optional) 
Color grading is shifting the colors of all segments in a video to set a mood or adopt consistency. 
 

Color Grading basics (without LUT’s): 
https://www.youtube.com/watch?v=8lTUqg9uHRg  
https://www.youtube.com/watch?v=Or10yLJmDp8  

Color Grading with LUTs: 
https://youtu.be/8FzX0Sz6-7Q 

 
 

Edit Clips   
 

 
 CUT / MOVE / DELETE CLIPS 

1. Use the razor tool (or “C” on keyboard) to cut a clip into pieces on the timeline. 
2. Use the selection tool to move clips on the timeline. 
3. Use the “Delete” key to delete a selected clip. 

 

         
 
 

 COPY / PASTE CLIPS 
1. To copy/paste, select your clip and right-click for options or use Ctrl/Command-C and V. 
 

 
 

 DELETE SPACE 
To delete the empty space, click on the space and click the “Delete” key. 
 

 
 

Back To Top 

https://www.youtube.com/watch?v=8lTUqg9uHRg
https://www.youtube.com/watch?v=Or10yLJmDp8
https://www.youtube.com/watch?v=8FzX0Sz6-7Q&t=0s
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 RIPPLE DELETE (delete video clip and the gap left behind) 
Ripple deleting will delete the element and also the gap it leaves behind on the timeline. 
 

 
 

 SHORTEN A CLIP 
1. Select the clip you want to shorten. 
2. Position your cursor over the end you want to shorten. Then, click and drag. 

 

 
 

 OPTIONAL: PRE-EDIT A CLIP IN THE SOURCE PANEL 
If you want to create shorter clips before placing them on the timeline: 
1. In the Project Panel, select the “Media Browser” tab to see your bins/folders. 
2. In the Source Panel (upper left) click the “Source” tab 
3. To trim your clip, move the playhead to your inpoint and click “I” on the keyboard. Then move 

playhead to out point and click “O.”  
4. Then drag the clip from that panel to the timeline. 
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Add Audio   
 

 
 ADD AUDIO TO TIMELINE  

Drag your audio clip from the media bin (Project Panel) to the timeline, on an audio track. 
 

 
 
 

 ADJUST THE VOLUME AS NEEDED 
The easiest way to do this is to: 
1. Expand the size of the audio clip (see How to Increase Timeline View on a previous page) 
2. You will see a white horizontal line across your audio clip. 
3. Drag it down to decrease volume or up to increase volume. 

 

 
 
 
 
 
 

Back To Top 
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 FADE MUSIC IN AND OUT 

This video demonstrates: 
https://www.youtube.com/watch?v=QaAgRHz5YbQ 
 
- Go to Window > Effects 
- Click on “Audio Transitions” and “Crossfade” 
- Choose “Constant Power” if you want the smoothest fades 
- Drag the effect onto the end of your audio track. 
- Drag out the effect icon to make the fade as long or short as 
you like. 
- To fade in, drag the effect to the start of the music and use the 
same methods to alter. 
 
 
 

 
 ADDITIONAL SOUND ADJUSTMENTS 

View this video: https://www.youtube.com/watch?v=TjfRDHod_uA (Vince Opra) 
 
 

 UNLINK VIDEO & AUDIO (to delete one or the other on a clip) 
By default, the audio of a video clip moves with the clip.  
If you want to be able to edit audio and video separately, right-click on the clip and select “unlink.” 
Now you can manipulate audio and video separately, or delete one or the other. 
 

 
 
 
 
 
 
 
 
 

https://www.youtube.com/watch?v=QaAgRHz5YbQ
https://www.youtube.com/watch?v=TjfRDHod_uA
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 CHANGE AUDIO SOURCES (external, internal, etc.) 

Edit > Preferences > Audio Hardware 
 
 

 
 
 

Transitions & Effects   
 

 
 

 SLOW MOTION / FAST MOTION:  
1. Right-click on the video clip and choose Speed/Duration.  
2. You will see speed 100%.  
To slow down clip, decrease the percentage. To increase speed, increase the percentage  
3. To keep audio/voices at normal pitch, click “Maintain Audio Pitch” (Optional). 
 

                 
 
 
 
          
 
 

Back To Top 
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 TRANSITIONS 

1. Open your Effects Panel (Windows > Effects). 
2. Select Video Transitions. 
 

 
 
3. You will see the transition choices open (see screenshot below).  
4. Choose “Cross Dissolve” (a popular option) and drag it onto a single clip OR between two clips. 
5. You will see the brown effects bar appear on the clip(s) in the timeline. 
6. Play your video to see the transition effect. 
7. To adjust the length of the dissolve, drag the brown bar on your clip in the timeline. 
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Text Effects   
 

 
 TEXT TOOL 

1. Choose the text tool 
2. Drag a textbox on your video 
3. Type the words you want. 
4. Use selection tool to move, scale, and rotate text. 

 

       
 
 

 TEXT EFFECTS:  
1. With your “Effects” Panel still open on the right (Window > Effects), select some text on the video.  
2. You should see the “Essential Graphics” effects controls open in the Effects Panel.  

If not, go to Window > Essential Graphics. 
3. Adjust font, style, color, background, alignment, kerning, leading, tracking, etc. 
 

 
 

 TEXT ANIMATION TEMPLATES 
1. In the Essential Graphics Panel, click the Browse tab at the top. 
2. Choose an animation or text effect and drag it to the timeline. The words will appear in pink clips. 
3. To change the words in the animation, click the type on the video preview screen and edit.  

 

Back To Top 
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 CREATE GREAT CAPTIONS 
Make your video fully accessible with excellent captions (YouTube captions are glitchy). 
See this video: How to Easily Create Subtitles in Adobe Premiere Pro 
 
 

Create Animation   
 

 
 TEXT ANIMATION TEMPLATES 

(See Previous Section on Text Effects) 
 

 ANIMATING ZOOMS (in and out) 
YOUTUBE: “How to Zoom in on Premiere Pro (Tutorial)” by FilterGrade 
 

 Live Writing (e.g., handwriting) and “Growth” Effect 
YOUTUBE: New Plugin by Premiere Gal 
 

 KEYFRAME ANIMATION 
YOUTUBE: “How to Use Keyframes for Beginners” (Vince Opra) 
 

 EASY ANIMATED SUBTITLES & TEXT 
YOUTUBE: “How to Create Animated Subtitles in Premiere Pro” (Vince Opra) 
 

Replace Background   
 

 
No Green Screen: 
How to Remove Video Backgrounds with Adobe Premiere 
HELPFUL TIP: Stand against a different colored wall than any color that’s in your subject. 
With Green Screen: 
How to Use a Green Screen with Adobe Premiere 

Back To Top 

Back To Top 

https://youtu.be/LL3H85pqHGY?si=qMNeKvnFYa2XnkYQ
https://www.youtube.com/watch?v=UxYyVKhvIK0
https://www.youtube.com/watch?v=VROCk8zyBX0
https://www.youtube.com/watch?v=XwJf1FK3NA8
https://www.youtube.com/watch?v=A0BldihvoBo
https://www.youtube.com/watch?v=DY9qxl3-p08
https://www.youtube.com/watch?v=GSTYNmDCFe8
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Export Video   
 

 
 

 HOW TO EXPORT YOUR VIDEO 
 

1. Go to File > Export > Media 
2. Name the MP4 you’re exporting. 
3. Identify the location where you want the file saved 
4. Keep defaults for the rest of settings 

(NOTE: H264 is the codec for mp4) 
5. Click “Export.” It can take time to render. This is normal. 

 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Back To Top 
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Troubleshooting   
 

 
 

 MY COMPUTER FROZE UP / STOPPED WORKING RIGHT 
Restart your computer. It’s normal for your computer to slow down gradually and stop working when 
you use big programs like Premiere Pro. It means your RAM is running low (Random Access Memory). 
RAM refreshes when you restart your computer. 
 

 MY EXPORTED VIDEO HAS IMAGES BUT NO SOUND 
These are known issues with recent versions of Premiere when used with iPhone footage. Most of the 
time, you should have no problem, but if you do, try this before you export:  
 
1. Go to: File > Project Settings > General > Renderer 
2. You will see the setting "GPU Exceleration." Change it to "Engine Software Only." 
3. Try again to export and see if it works. 
 

 MY EXPORTED VIDEO IS OVEREXPOSED 
 

1. Go to Sequence > Sequence Settings.  
2. Click the box called “Auto Tone Map Media.” 
 
 

Retouching   
 

 
 

 EFFECTS CONTROL 
 

1. Soften Pixels 
Video Effects > Immersive Video > VR D-Noise 
Effects Control: D-Noise .05 or .08 
 
2. Glow 
Video Effects > Immersive Video > Glow 
Effects Control: Glow Brightness .20 
 

 LUMETRI COLOR 
 

Warmer: Temperature 3 

Back To Top 

Back To Top 


